[server] Freenas Server met ZFS issues

Door Gaffel op dinsdag 12 februari 2013 20:19 - Reacties (12)
Categorie: Dagelijks spul, Views: 4.180

Ik heb een tijd geleden van een mede tweaker 4x 2TB HDD's mogen overnemen.
Deze zouden in eerste instantie in de plaats komen van mn 2x 2TB en 1x 1TB setup.
Maar gelukkig had ik genoeg ruimte en bij nader inzien heb ik alle schijven door Freenas bij mijn zfs pool Tank geimporteerd. Een grote fout nu blijkt..
Ik heb in mijn case een PicoPSU van 150W zitten.

Denk dat ik het me gemakkelijk maak, hierbij de hardware lijst van mn server:

#ProductPrijsSubtotaal
1Asus AT4NM10T-I§ 0,-§ 0,-
1Lian Li PC-Q25B§ 103,-§ 103,-
1ICIDU IDE Power Splitter§ 5,85§ 5,85
1Xigmatek Mono Cool Fan Controller (3fans)§ 5,51§ 5,51
1Zalman ZM-RC100§ 1,15§ 1,15
1Streacom PicoPsu 150W + 150W Adapter Power Kit§ 75,49§ 75,49
1Intel 330 60GB§ 59,99§ 59,99
Bekijk collectie
Importeer producten
Totaal§ 250,99


Nu is het zo dat een van de HDD's van 2TB plots het niet meer deed na het importeren. De 4x 2TB zaten in een raidz2 en 1 failed HDD bleek meteen mn hele Tank degraded te maken.
Gelukkig is degraded niet gelijk aan failed en kon ik nog steeds bij mn data op dat moment.

Mijn eerste gedachte was dat mn HDD gewoon stuk was en dat ik hem kon opsturen naar de leverancier. Dus ik in de BIOS de SMART data uitlezen.. Smart status was OK!
Na een tijdje verder te zoeken naar informatie over de HDD's in de bios zag ik de voltages. De 5V rail werd rood werd aangegeven met 4.403 V.
Dit was met alle HDD's erin, ik haalde er een HDD uit en de 5V rail sprong weer op zwart (normaal).

Toen ik weer met al mijn HDD's erin opstartte en het gebruikelijke "zpool status -v Tank" uitvoerde viel me op dat er wel 3 HDD's op unavailable stonden. Dit betekende dat mijn zfs Tank wel degelijk Failed was en ik kon niet meer bij mijn data.

Vervolgens 1x een HDD eruit gedaan, restart en een "zpool clear -F Tank" && "zpool status -v Tank" later bleek alles weer "redelijk" normaal en was mn Tank weer degraded en mn data weer bereikbaar.

Ik had nooit verwacht dat 1 HDD zoveel verschil kon maken tussen "leven en dood" van mn server.
Ik ben nu druk bezig mn belangrijke data te kopieren naar een van de HDD's uit de Tank die ik eruit heb gehaald. Daarna zal ik de hele Tank verwijderen en volledig opnieuw opbouwen zonder de 1x 1TB HDD erin...
Hopelijk dat dit mn probleem oplost en ik niet verder hoef te zoeken naar oplossingen.

Het vreemste vind ik dat 7x 3.5" HDD's (green en niet-green), 1 SSD en mn mobo/ raid controller bij elkaar blijkbaar zoveel vreten dat mn 5V rail het niet meer trekt. Terwijl ik juist dacht met 150W meer dan voldoende speel ruimte te hebben voor zoveel HDD's... Weet iemand misschien hoe dit precies zit?

[server] Freenas Server met ZFS issues

Door Gaffel op dinsdag 12 februari 2013 20:14 - Reacties (1)
Categorie: Dagelijks spul, Views: 2.633

Ik heb een tijd geleden van een mede tweaker 4x 2TB HDD mogen overnemen.
Deze zouden in eerste instantie in de plaats komen van mn 2x 2TB en 1x 1TB setup.
Maar gelukkig had ik genoeg ruimte en bij nader inzien heb ik alle schijven door Freenas bij mijn zfs pool Tank geimporteerd. Een grote fout nu blijkt..
Ik heb in mijn case een PicoPSU van 150W zitten.

Denk dat ik het me gemakkelijk maak, hierbij de hardware lijst van mn server:

#ProductPrijsSubtotaal
1Asus AT4NM10T-I§ 0,-§ 0,-
1Lian Li PC-Q25B§ 103,-§ 103,-
1ICIDU IDE Power Splitter§ 5,85§ 5,85
1Zalman ZM-RC100§ 1,15§ 1,15
1Adaptec AAR-1430SA§ 109,95§ 109,95
1Streacom PicoPsu 150W + 150W Adapter Power Kit§ 75,49§ 75,49
1Intel 330 60GB§ 59,99§ 59,99
Bekijk collectie
Importeer producten
Totaal§ 355,43


Nu is het zo dat een van de HDD van 2TB plots het niet meer deed na het importeren. De 4x 2TB zaten in een raidz2 en 1 failed HDD bleek meteen mn hele Tank degraded te maken.
Gelukkig is degraded niet gelijk aan failed en kon ik nog steeds bij mn data op dat moment.

Mijn eerste gedachte was dat mn HDD gewoon stuk was en dat ik hem kon opsturen naar de leverancier. Dus ik in de BIOS de SMART data uitlezen.. Smart status was OK!
Na een tijdje verder te zoeken naar informatie over de HDD in de bios kwam ik tegen de gegevens van de voltages aan. De 5V rail werd rood werd aangegeven met 4.4 en nog wat op het scherm.
Dit was met alle HDD erin, ik haalde er een HDD uit en de 5V rail sprong weer op zwart (normaal).

Toen ik weer met al mijn HDD erin opstartte en het gebruikelijke "zpool status -v Tank" uitvoerde viel me op dat er wel 3 HDD op unavailable stonden. Dit betekende dat mijn zfs Tank wel degelijk Failed was en ik kon niet meer bij mijn data.

Vervolgens HDD eruit gedaan, restart en een "zpool clear -F Tank" && "zpool status -v Tank" later bleek alles weer "redelijk" normaal en was mn Tank weer degraded en mn data weer bereikbaar.

Ik had nooit verwacht dat 1 HDD zoveel verschil kon maken tussen "leven en dood" van mn server.
Ik ben nu druk bezig mn belangrijke data te kopieren naar een van de HDD uit de Tank die ik eruit heb gehaald. Daarna zal ik de hele Tank verwijderen en volledig opnieuw opbouwen zonder de 1x 1TB HDD erin...
Hopelijk dat dit mn probleem oplost en ik niet verder hoef te zoeken naar oplossingen.

Het vreemste vind ik dat 7x 3.5" HDD (green en niet-green), 1 SSD en mn mobo/ raid controller bij elkaar blijkbaar zoveel vreten dat mn 5V rail het niet meer trekt. Terwijl ik juist dacht met 150W meer dan voldoende speel ruimte te hebben voor zoveel HDD's... Weet iemand misschien hoe dit precies zit?

[home] Televisie ontvangen zonder kabel.

Door Gaffel op vrijdag 10 augustus 2012 14:50 - Reacties (15)
Categorie: Dagelijks spul, Views: 6.524

Sinds 1 aug. verhuisd naar midden-centrum van Haarlem! Dus nu is de speurtocht is begonnen naar nieuwe spullen zoals inboedel, maar ook spullen voor de aan te leggen techniek.

Doordat we een oude woning delen met anderen is er geen kabel beschikbaar, ook hebben we geen mogelijkheid om even een gat in de muur de boren voor een kabel naar een schotel.

Helaas dan maar naar dvb-t kijken dus... Iets waar ik niet echt warm van wordt :(
Aangezien dvb-t nog geen HD specificatie heeft (en nooit gaat krijgen?) ben ik al helemaal niet blij om een digitenne abbonement af te sluiten.

Helaas zijn de mogelijkheden in deze wereld vooralsnog zeer beperkt:
- DVB - C is alleen via coax kabel te krijgen
- DVB - C(HD) is ook alleen via coax kabel te krijgen
- DVB - S(HD) is alleen via satelliet te ontvangen
- DVB - T is te ontvangen via usb-dongle of reciever met externe ontvanger.

Omdat dvb-t toch echt mijn enige optie zal blijken, ben ik maar opzoek gegaan naar een geschikte SCART naar HDMI converter.
Helaas heb ik alleen een computerscherm en een Onkyo reciever met HDMI, waardoor ik echt alleen HDMI kan tonen op mijn scherm.

Een mogelijke converter die ik zo even heb gevonden is: Konig HDMI converter
Deze converter is tot 720P in staat om door te voeren, wat mijn ogen toch weer wat blijer maakt.

Toch heb ik de keuze nog niet kunnen maken, voornamelijk vanwege de mogelijke slechte kwaliteit.

Ik zou graag willen weten of iemand met eenzelfde setup ervaring heeft en hetzelfde probleem heeft als ik?

tips en comments zijn erg welkom :)