[server] Freenas Server met ZFS issues

Door Gaffel op dinsdag 12 februari 2013 20:19 - Reacties (12)
Categorie: Dagelijks spul, Views: 2.656

Ik heb een tijd geleden van een mede tweaker 4x 2TB HDD's mogen overnemen.
Deze zouden in eerste instantie in de plaats komen van mn 2x 2TB en 1x 1TB setup.
Maar gelukkig had ik genoeg ruimte en bij nader inzien heb ik alle schijven door Freenas bij mijn zfs pool Tank geimporteerd. Een grote fout nu blijkt..
Ik heb in mijn case een PicoPSU van 150W zitten.

Denk dat ik het me gemakkelijk maak, hierbij de hardware lijst van mn server:

#ProductPrijsSubtotaal
1Asus AT4NM10T-I¤ 0,-¤ 0,-
1Lian Li PC-Q25B¤ 103,-¤ 103,-
1ICIDU IDE Power Splitter¤ 5,85¤ 5,85
1Xigmatek Mono Cool Fan Controller (3fans)¤ 5,51¤ 5,51
1Zalman ZM-RC100¤ 1,15¤ 1,15
1Streacom PicoPsu 150W + 150W Adapter Power Kit¤ 75,49¤ 75,49
1Intel 330 60GB¤ 59,99¤ 59,99
Bekijk collectie
Importeer producten
Totaal¤ 250,99


Nu is het zo dat een van de HDD's van 2TB plots het niet meer deed na het importeren. De 4x 2TB zaten in een raidz2 en 1 failed HDD bleek meteen mn hele Tank degraded te maken.
Gelukkig is degraded niet gelijk aan failed en kon ik nog steeds bij mn data op dat moment.

Mijn eerste gedachte was dat mn HDD gewoon stuk was en dat ik hem kon opsturen naar de leverancier. Dus ik in de BIOS de SMART data uitlezen.. Smart status was OK!
Na een tijdje verder te zoeken naar informatie over de HDD's in de bios zag ik de voltages. De 5V rail werd rood werd aangegeven met 4.403 V.
Dit was met alle HDD's erin, ik haalde er een HDD uit en de 5V rail sprong weer op zwart (normaal).

Toen ik weer met al mijn HDD's erin opstartte en het gebruikelijke "zpool status -v Tank" uitvoerde viel me op dat er wel 3 HDD's op unavailable stonden. Dit betekende dat mijn zfs Tank wel degelijk Failed was en ik kon niet meer bij mijn data.

Vervolgens 1x een HDD eruit gedaan, restart en een "zpool clear -F Tank" && "zpool status -v Tank" later bleek alles weer "redelijk" normaal en was mn Tank weer degraded en mn data weer bereikbaar.

Ik had nooit verwacht dat 1 HDD zoveel verschil kon maken tussen "leven en dood" van mn server.
Ik ben nu druk bezig mn belangrijke data te kopieren naar een van de HDD's uit de Tank die ik eruit heb gehaald. Daarna zal ik de hele Tank verwijderen en volledig opnieuw opbouwen zonder de 1x 1TB HDD erin...
Hopelijk dat dit mn probleem oplost en ik niet verder hoef te zoeken naar oplossingen.

Het vreemste vind ik dat 7x 3.5" HDD's (green en niet-green), 1 SSD en mn mobo/ raid controller bij elkaar blijkbaar zoveel vreten dat mn 5V rail het niet meer trekt. Terwijl ik juist dacht met 150W meer dan voldoende speel ruimte te hebben voor zoveel HDD's... Weet iemand misschien hoe dit precies zit?

Volgende: [server] Freenas Server met ZFS issues 02-'13 [server] Freenas Server met ZFS issues

Reacties


Door Tweakers user ShitHappens, dinsdag 12 februari 2013 20:23

Omdat je HDD's bij het opstarten zo veel verbruiken dat het totaal even boven die 150W uit komt. Als er een manier zou zijn dat de schijven één voor één kunnen gaan starten, dan gaat het je nog wel gaat lukken.

Door Tweakers user EnerQi, dinsdag 12 februari 2013 20:37

De opstartpiek is te groot. Geen idee welke harde schijven je overgenomen hebt, maar +- iedere harde schijf heeft 20 tot 30 watt nodig bij het opstarten. De oplossing is hetgene wat in de eerste reactie staat, de harde schijven een voor een opstarten (Staggered spin-up )

Door Tweakers user Gaffel, dinsdag 12 februari 2013 20:41

Een goede optie indien dit volledig automatisch kan ;). Want mn NAS gaat elke nacht weer uit aangezien ik in een studio van 30m2 woon en er nogal wat herrie kan zijn waar ik niet door kan slapen :P

Door Tweakers user mux, dinsdag 12 februari 2013 21:31

Hoeveel RAM heb je erin zitten? Dat is i.h.a. naast de HDDs het enige dat op 5V hangt.

Door Tweakers user Milosonator, dinsdag 12 februari 2013 21:35

Ik denk ook dat die 150W niet 100% beschikbaar is op de 5V rail. Heb je de referentie van de PicoPSU erbij gepakt?

Door Tweakers user Gaffel, dinsdag 12 februari 2013 21:48

@ mux: ik heb 2x 2GB laptop DDR3 ram erin
@Milo: Kom op het volgende uit met een google search: " the 150W (pico psu) version sources 30W on 5V [...] (don't have a datasheet handy)"

30 W op de 5V rail lijkt me vrij weinig voor 7x HDD en 2x 2GB ram :P
Als ik grofweg 5W per HDD neem kom ik al met 7 HDD's op 35W..
Denk dat ik mijn probleem gevonden heb.

Zou het nog mogelijk zijn om alsnog die 7x HDD werkend te krijgen door bijv de 5V uit USB te halen ipv de 5v rail ?

Door Tweakers user ShitHappens, dinsdag 12 februari 2013 22:16

Nee want dat komt alsnog uit dezelfde voeding :p

Door Tweakers user Gaffel, dinsdag 12 februari 2013 22:28

niet vanaf de 5V rail lijkt me, dus dan zou het toch moeten kunnen? Misschien weet @mux het wel...

Door Tweakers user CiPHER, dinsdag 12 februari 2013 23:20

Ik heb eens uitgerekend hoeveel ampère 3,5" desktopschijven gebruiken in combinatie wat PicoPSU kan leveren. Dat bleek ruimschoots voldoende. Maar jij hebt een Streacom, je zou kunnen opzoeken of die minder op de +5V kan leveren dan PicoPSU heeft opgegeven. Uit mijn hoofd zat ik bij 6-10 schijven op de helft wat PicoPSU kan leveren qua +5V. Notebookschijven verbruiken wel meer +5V dus dat ligt anders.

Door Tweakers user naftebakje, woensdag 13 februari 2013 07:57

Neem een wat steviger picoPSU, tenzij je een fikse wandeling in de wondere wereld van electronica wil en de +5V convertor zelf wat extra vermogen wil geven...
Ofwel zet je een extra convertor van 12V naar 5V in om enkele schijven apart voeding te geven, zo deel je ook de opstartpiek.

[Reactie gewijzigd op woensdag 13 februari 2013 07:58]


Door Tweakers user Gaffel, woensdag 13 februari 2013 08:15

Ik denk dat ik je eerste advies maar overneem naftebakje, want verstand van electronica heb ik niet genoeg. Wel eens mogen spelen met DC/AC converters en dergelijke, maar dat was altijd in een veilige omgeving, niet in mn server met gevoelige data :P

Door Tweakers user i-chat, woensdag 13 februari 2013 16:17

ik denk dat het ahankelijk is van wat je verder nog verbruikt... als je nog meer dan genoeg ruimte op je 12v rail hebt zou je idd daar wat strom vandaan kunnen trekken en een omvormer ertussen proppen ... misschien kan mux je daar bij helpen...

een 2e optie zou zijn om er een 2e voeding bij te stoppen er zijn namelijk mogelijkheden om 2 voedingen tegelijk te starten... door ze te koppelen... in dat geval zou je dus een kleinere apparte voeding voor je schijven kunnen gebruiken ik gok namelijk dat er niet veel pico psu's zullen zijn die meer dan dit over de 5v rail stampen.. ze zijn immers vooral bedoeld voor kleine bescheiden pc's (al dan niet met een extra grafische kaart (die 12 volt trekt ipv 5)... ik ben geen ras techneut maar wellicht zou zoiets moeten kunnen werken???

[Reactie gewijzigd op woensdag 13 februari 2013 16:19]


Reageren is niet meer mogelijk